PDA

View Full Version : error running configurator.



Anonymous
02-04-2003, 02:12 PM
hello while running the configurator i get the following error.

Execute($elementContents); if ($recordSet === false) die ("ERROR - $elementContents"); } echo "
and it does not run.
i followed the instructions, on the common file. i would link to the info file however i am setting this up on a local host computer, using windows xp.
i have included the site information in the config file, can some one tell me how this is inccorrect or what the problem is.

$config[baseurl] = 'http://localhost';
$config[basepath] = 'C:\\open-realty';

cjreynolds
02-04-2003, 03:01 PM
did you make sure to set up your database login

like the

$db_user = ''; //database user
$db_password = ''; //database password
$db_database = ''; //database definition file
$db_server = 'localhost'; //database server -- usually localhost, but one never knows

fill in the quotes with the appropriate information to log into the mysql database or which ever your using.

You comon.php needs to know how to interface with the database. Make sure you have created a new database as wells as a user to access it in your mysql admin.

hope this helps a bit

Anonymous
02-04-2003, 04:08 PM
i think i set it correctly, first off, two questions, do i run the config from my hard drive or the server. second i am using an access database, here is my settings.
$db_user = 'admin';
$db_password = 'hobomob';
$db_database = 'Lifstyle';
$db_server = 'localhost';



the dabase definition is the name of the dabase correct?. i am very new to php and would appriciate, the help

cjreynolds
02-04-2003, 04:45 PM
yes your correct,


from what I understand is that the configurator works only with mysql, but you will have to verify that with ryan a.k.a. greengiant.
You might have to setup your tables and fields manually, unless you can run the .sql script in the access database to set it up for you. the .sql file is in the main directory when unzipped, its called openrealty.sql. the configurator grabs this file and sets up your database with the correct catergories and fields, thats why the login information is crucial to setting the database up correctly.

Anonymous
02-04-2003, 04:49 PM
thank you guess i will download mysql and try it. thank you.

Anonymous
02-05-2003, 12:32 AM
ok downloaded mysql , setup the blank database and now it does not work still same error, down loaded php for the server side, still not working.

Denver Dave
02-06-2003, 10:02 PM
This does not really answer your question, but have you tried running in the openrealty.sql file from a phpMyAdmin application?

Anonymous
06-21-2003, 03:12 AM
I too have had the same error. I'm running mine from a webserver though.

I've filled in the mysql details, executed configurator and i get the following error:

Execute($elementContents); if ($recordSet === false) die ("ERROR - $elementContents"); } echo "

I decided to phpmyadmin the sql file manually, but i still have a problem.

Any ideas?

Cheers!
AaronUV

AaronUV
06-21-2003, 06:44 AM
Turns out the you cant install open-realty under a directory like this...

http://www.yoursite.com/~user

RealtyOne
06-21-2003, 07:00 AM
I had not heard that before, however i just tested and the program still works fine with /~realty so that isnt the problem i think.

Going by previous posts you have all required data in your database so the configurator is no longer the problem as you have skipped that part :).
Check your common file for errors not relating to the database.
Tell us more about what your are loading it too so we can help with more accuracy.

AaronUV
06-21-2003, 09:34 PM
It wasnt about the directory itself, but the path address i typed in the common.php

I only found this out by installing it in a root dir instead of a sub folder....

www.vunoraa.com/hvr/