PDA

View Full Version : Installation problems [SOLVED]



lkoelbel
05-04-2004, 11:18 AM
Hi all,

New to OR... trying to set up a local FSBO site... I've got OR on my server, common.php set up, and then ran the configurator only to get this message:
0 -- CREATE TABLE UserDB (ID int(11) NOT NULL auto_increment,user_name varchar(80) NOT NULL default '',emailAddress varchar(80) NOT NULL default '',Comments text NOT NULL,user_password varchar(50) NOT NULL default '',isAdmin char(3) NOT NULL default 'No',canEditForms char(3) NOT NULL default 'No',creation_date date NOT NULL default '0000-00-00',canFeatureListings char(3) NOT NULL default 'No',canViewLogs char(3) NOT NULL default 'No',last_modified timestamp(14) NOT NULL,hitcount int(11) NOT NULL default '0',canModerate char(3) NOT NULL default 'no',PRIMARY KEY (ID),UNIQUE KEY ID (ID,user_name),KEY ID_2 (ID));

I set the mysql database up manually like the instructions said... however, I can not get any admin log in screen... running configurator keeps giving me the error message above... my IP Host is no help... at least not the person I got... my base path was confirmed as correct so right now I'm lost with this and can't seem to find the error... can someone please help...

Thanx =}

Mick
05-04-2004, 02:02 PM
The snippet you gave of the configurator.php is the normal output. However if there was a RED error message along with that then you do have a problem.

Did you setup the database information properly in your common.php??

lkoelbel
05-04-2004, 02:39 PM
Hi Mick,

Thanx for replying... after 3 calls to my host and reuploading etc... I now get this message below: (and in red too at the ERROR part)... my settings are supposedly correct and my provider confirmed it too... they said they can't see what's wrong and that everything on the server was done right.... to check with OR for support... so here I am again... =}

0 -- CREATE TABLE default_UserDB (ID int(11) NOT NULL auto_increment,user_name varchar(80) NOT NULL default '',emailAddress varchar(80) NOT NULL default '',Comments text NOT NULL,user_password varchar(50) NOT NULL default '',isAdmin char(3) NOT NULL default 'No',canEditForms char(3) NOT NULL default 'No',creation_date date NOT NULL default '0000-00-00',canFeatureListings char(3) NOT NULL default 'No',canViewLogs char(3) NOT NULL default 'No',last_modified timestamp(14) NOT NULL,hitcount int(11) NOT NULL default '0',canModerate char(3) NOT NULL default 'no',PRIMARY KEY (ID),UNIQUE KEY ID (ID,user_name),KEY ID_2 (ID));
ERROR - CREATE TABLE default_UserDB (ID int(11) NOT NULL auto_increment,user_name varchar(80) NOT NULL default '',emailAddress varchar(80) NOT NULL default '',Comments text NOT NULL,user_password varchar(50) NOT NULL default '',isAdmin char(3) NOT NULL default 'No',canEditForms char(3) NOT NULL default 'No',creation_date date NOT NULL default '0000-00-00',canFeatureListings char(3) NOT NULL default 'No',canViewLogs char(3) NOT NULL default 'No',last_modified timestamp(14) NOT NULL,hitcount int(11) NOT NULL default '0',canModerate char(3) NOT NULL default 'no',PRIMARY KEY (ID),UNIQUE KEY ID (ID,user_name),KEY ID_2 (ID));

Mick
05-04-2004, 03:34 PM
Yep.. that's the error message...

Although you haven't provided me any information that I could use to provide you a better explination other than... Check your database settings in your common.php file.

Is there any chance you could provide a link to your website? Perhaps Email or PM me your common.php file? or perhaps FTP login information so that I could take a look at your common.php file?

That error message could be caused by many things... you could have already successfully ran the configurator.php file and now it can't load the stuff into the database a second time, in this case your site is probably working properly already.

your database name, username or password are incorrect in your common.php file OR your user does not have permissions to access the database you setup.

lkoelbel
05-04-2004, 07:16 PM
Hi again Mick,

Emailed you the file...

Thanx =}

Mick
05-04-2004, 09:19 PM
Fixed problem. :D

lkoelbel
05-04-2004, 09:38 PM
MICK IS MY HERO!!!!!! =}