PDA

View Full Version : free site where I can test the script?



petergun
06-27-2004, 10:51 PM
I tried installing it on Tripod (Lycos) but I can't fix the bugs associated with it. Any other places with PHP (MySQL) that I should try out?

Fat Lizard
06-28-2004, 07:36 AM
I tried installing it on Tripod (Lycos) but I can't fix the bugs associated with it. Any other places with PHP (MySQL) that I should try out?

Download the bundled Apache/PHP/MySQL at http://firepages.com.au and run it on http://localhost (your local/home PC)

RealEstate
06-28-2004, 10:42 AM
lizard, thanks for that advice. surely will help lots of us.

petergun
06-28-2004, 10:04 PM
Downloaded that bundle.
How do I set up a database on my own computer? I'm running Windows XP if that matters..

pbflash
06-28-2004, 11:58 PM
The bundle includes phpMyAdmin so you can use that or just run the configurator.

Fat Lizard
06-29-2004, 09:02 AM
Unless it's changed since I grabbed it, you should be able to enter:
http://localhost/phpmyadmin/
to get to the local version of phpMyAdmin

Other than that, fire up the local server and use the configurator

petergun
06-29-2004, 11:48 PM
Unless it's changed since I grabbed it, you should be able to enter:
http://localhost/phpmyadmin/
to get to the local version of phpMyAdmin

Other than that, fire up the local server and use the configurator

shiet.......


"Welcome to phpMyAdmin 2.3.2


Error

MySQL said:


Can't connect to MySQL server on 'localhost' (10061)"

Fat Lizard
06-30-2004, 02:12 AM
Sounds like you haven't started the server/mysql
Have a look inthe phpDev installation directory for 98-ME-phpdev_start.bat
If that's not there, look at he readme file to find out how to start the server

From the readme file I have:

>>You have just unzipped phpdev423 , the NSIS installer 'should' have run
>>the install script for you
>>
>>JUST IN CASE... run the
>>
>>X:\your_install_dir\install_phpdev.bat batch file (double click it)
>>
>>IMPORTANT - make sure that no existing apache or PHP or MySQL
>>programs are running else the installation it wont work.
>>
>>then you can click on either the 98-ME-PHPDEV_START.BAT (if you run
>>win95/98/ME) or the 2K-NT-XP-PHPDEV_START.BAT if you run NT/2K/XP
>>
>>this will start apache mysql and open your preferred brower hopefully at
>>localhost
>>if your browser does not open, open it yourself and type http://localhost/
>>in the address bar and hit enter/click go , you should get a directory
>>listing - find the start_here.htm link and errr start there.
>>

petergun
07-01-2004, 12:13 AM
Damnit... couldn't figure all these variables myself so I restored my include/common...

what do I put down for these:

$config['basepath'] = '/home/transpar/www/demo';

$db_user = ''; //database user
$db_password = ''; //database password
$db_database = ''; //database definition file
$db_server = 'localhost'; //database server -- usually localhost, but one never knows

Fat Lizard
07-01-2004, 12:31 AM
Damnit... couldn't figure all these variables myself so I restored my include/common...

what do I put down for these:

$config['basepath'] = '/home/transpar/www/demo';

$db_user = ''; //database user
$db_password = ''; //database password
$db_database = ''; //database definition file
$db_server = 'localhost'; //database server -- usually localhost, but one never knows

Ok, if you're running it locally, try these:
$db_user = 'root';
$db_password = ''; // leave this empty
$db_database = 'the_name_of_your_database';
$db_server = 'localhost';

Depending on where you installed phpDev to .. But as a guess, which you can check, and change if needed, it might be:

$config['basepath'] = 'c:/phpdev/www/demo';

Note:
Assuming you installed phpDev into drive C:/ as above, then http://localhost will resolve to c:/phpdev/www

PS
Have you been able to get the server started, and access phpMyAdmin

petergun
07-01-2004, 12:44 AM
Thanks, I'm getting things working. However........

"Warning: Failed to connect to mailserver, verify your "SMTP" setting in php.ini in c:\phpdev\www\demo\include\main.php on line 1349
There's been a problem -- please contact the site administrator"

mail.mydomain.com? Change this to??

Fat Lizard
07-01-2004, 12:14 PM
Thanks, I'm getting things working. However........

"Warning: Failed to connect to mailserver, verify your "SMTP" setting in php.ini in c:\phpdev\www\demo\include\main.php on line 1349
There's been a problem -- please contact the site administrator"

mail.mydomain.com? Change this to??

Let me have another guess here, and see if we can get a bit closer ...

Browse your /windows directory, and locate phpdev.ini
Somewhere in there look for the entry:

[mail function]
; For Win32 only.
SMTP = enter_your_mail_server_here

That is just for trying to get around your mail server message.
The other line, "There's been a problem -- please..." indicates an error elsewhere.

If you enter your mail server, the one you use for your local ISP, and run OR while connected to the internet, you may (should?) receive email(s) with the offending SQL statements.

Make sure you set the email address correctly in your common.php
$config['admin_email'] = 'changeme@default.com'; // all email which is sent from the site will come from this address

Do you have the server running ok?
Can you access the DB using phpMyAdmin?

FL

petergun
07-01-2004, 08:55 PM
Yea, everything's fine except the damn SMTP server... I use Verizon for my high-speed cable and tried smtp.verizon.net but it's not working.. anyone know of a public smtp server?

Fat Lizard
07-01-2004, 09:04 PM
What setting do you use for your email client, as your outgoing mail server?

petergun
07-01-2004, 09:24 PM
I don't have one