PDA

View Full Version : smtp problems



chasferr
08-07-2004, 12:49 PM
I am using Windowsxp Pro, IIS, PHP 4, MYSQL. After installation, I am getting the following error.

Warning: mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in


I have changed settings, I get the error description to go away. However, I still get an error referring me to the administrator, with no description of the error.

Need help

Chasferr

pbflash
08-07-2004, 01:01 PM
If you're getting an error like "There's been a problem. Please contact the sight admin". It is most likely an sql error. If you have the admin email set in common.php you should receive an email showing you what the eroor is.

Mick
08-07-2004, 01:01 PM
Well... personally I don't know why so many people seem to want to use IIs lately... I'd try one of the packages of Apache / mysql / php that are posted on the forums already many times.

To address your problem, most likely your database settings are incorrect in your common.php file. You're database settings must match the database name, username and password you have setup for your mysql database.

Either that or you haven't yet run your configurator.php file to load the data into the database yet.

chasferr
08-07-2004, 01:24 PM
Thanks guys, I think I found it. It was located in IIs. My user name didn't have permission. I had to add my user name to the list. Also, changed the allowed IP addresses to all. Since I am on cable, and it switches periodically.

For those of you that might be having the same problem. WindowsXP. Go to "Start" right click the "my computer" select "manage" goto "Services and applications" expand the tree, right click "default smpt virtual server" select "properties" On the "General Tab" make sure "IP Addresss" is set to "All Unassigned" select "Security Tab" If your user name isn't shown, add it.

That should do it.

Chasferr