In the Users section of the Site Config I have set the option of agents editing pages to NO, but the Edit Pages option is still showing available in the agents' admin.

What did I miss?

All help is GREATLY appreciated!