Results 1 to 7 of 7

Thread: Unable to Connect

  1. #1
    Join Date
    Sep 2008
    Location
    Lizella, GA
    Posts
    17

    Default Unable to Connect

    I'm going to lose my mind trying to solve this problem. I've searched the forum and can't seem to resolve my issue.

    I can't get past the database step because I get the same "unable to connect" that everyone else is getting. I've checked and rechecked my settings. I've created different blank databases and users and can't get it to work.

    The following are my settings. Can anyone tell me what I am doing wrong? I know you keep saying the settings have to be correct, and they really, really are. I can log on to the SQL database through my control panel, but I can't through Open Realty. This is my second installation on this site just trying to make it work.


    Database Type: mysql

    Database Server: localhost

    Database Name: bownut_or

    Database User: *moderated

    Database Password: *moderated

    Table Prefix: default_

    Base URL: http://www.retvshowcase.com

    Base Path: /hsphere/local/home/bownut/retvshowcase.com

  2. #2
    Join Date
    Aug 2008
    Location
    USA
    Posts
    26

    Default Re: Unable to Connect

    Hi bownut

    Will be glad to help
    see my PM

    AdSpace

    Quote Originally Posted by bownut View Post
    I'm going to lose my mind trying to solve this problem. I've searched the forum and can't seem to resolve my issue.

    I can't get past the database step because I get the same "unable to connect" that everyone else is getting. I've checked and rechecked my settings. I've created different blank databases and users and can't get it to work.

    The following are my settings. Can anyone tell me what I am doing wrong? I know you keep saying the settings have to be correct, and they really, really are. I can log on to the SQL database through my control panel, but I can't through Open Realty. This is my second installation on this site just trying to make it work.


    Database Type: mysql

    Database Server: localhost

    Database Name: bownut_or

    Database User:

    Database Password:

    Table Prefix: default_

    Base URL: http://www.retvshowcase.com

    Base Path: /hsphere/local/home/bownut/retvshowcase.com

  3. #3
    the_sandking's Avatar
    the_sandking is offline hadron remnant - Moderation Fachmann
    Join Date
    Apr 2003
    Location
    Nullspace
    Posts
    5,289

    Default Re: Unable to Connect

    The DB user you are using does not have permission to access the DB you setup for OR assuming that you setup a new DB for OR.

    You must grant all permissions to your DB user before running the installer.
    "Much of what looks like rudeness in hacker circles is not intended to give offense. Rather, it's the product of the direct, cut-through-the-BS communications style that is natural to people who are more concerned about solving problems than making others feel warm and fuzzy."

    "We gotta' go to the crappy town where I'm a hero!"
    -Hoban 'Wash' Washburne 2485-2519


    "When you’re born you get a ticket to the freak show. When you’re born in America, you get a front-row seat.."
    -George Carlin 1937-2008

    New to Open-Realty® and need help? Check the:
    -OR DOCUMENTATION -

    Important: Read this at least once in your lifetime
    How To Ask Questions The Smart Way

  4. #4
    Join Date
    Sep 2008
    Location
    Lizella, GA
    Posts
    17

    Default Re: Unable to Connect

    I set up a new database to be used for OR. I set up a database user for said database. I gave that user any, every, and all permissions. I've even tried setting up multiple users for one database, and neither user worked.

  5. #5
    Join Date
    Sep 2008
    Location
    Lizella, GA
    Posts
    17

    Default Re: Unable to Connect

    I've even tried using MySQL and PGSQL databases and users, taking care to make sure I had the correct databse type selected.

  6. #6
    Join Date
    Sep 2008
    Location
    Lizella, GA
    Posts
    17

    Unhappy Re: Unable to Connect

    bump ... Can anyone help me? Is this a case where I don't have the right base path or something? Does that field have anything to do with the lack of connection? I can get into my database through my website control panel.

    Today I have also tried installing the previous version (2.4.4 I think) and it still didn't work. I also CHMOD the include file to 777 to see if that would help. Still not working.

  7. #7
    Join Date
    Sep 2008
    Location
    Lizella, GA
    Posts
    17

    Red face Mystery solved

    I carefully went through the suggestions of each thread front the search with the phrase "unable to connect." After about six or seven threads, I found the answer in this post: http://support.open-realty.org/showt...ble+to+connect

    I wanted to make sure I put full documentation here so that others could benefit instead of having to search and search threads where there is no resolution or the resolution is not posted. The was resolved while installing Open Realty 2.4.4. I still have to go back and install the latest version.

    My host www.websitesource.com puts the MySQL database on a different server as suggested by Mike in the above thread. So instead of localhost for the databse, the SQL is hosted on something like this: mysql4.websitesource.com I found this information in the list of MySQL databases.

    So if you can't get around the unable to connect issue, try finding out if your database is hosted on a different server than your website. In that case, you database information would read more like this:

    Database Type: mysql

    Database Server: mysql4.websitesource.com (not localhost)

    Database Name: user_databasename

    Database User: user_user

    Database Password: password

    Table Prefix: default_

    Base URL: http://www.yourdomain.com

    Base Path: /hsphere/local/home/bownut/yourdomain.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •