Results 1 to 7 of 7

Thread: Not able to send mail to other domain alies

  1. #1
    Join Date
    Nov 2008
    Posts
    2

    Red face Not able to send mail to other domain alies

    i have installed properly open realty on the server it is working well axcept i'm not able to send mail to other email ids than my domain name.
    for eg. i'm getting new user notification in my admin mail id as admin mail id is admin@mydomain.com

    but if some new agent added and his mail id is abc@gmail.com them he is not getting any mail
    ie: contact agent, forgot passward or any.
    i talk with my server admin he said your server requires authentication,
    currently my outgoing mail setting are like this

    Outgoing Mail Server: mail.guntha.com (server requires authentication) port 26
    Outgoing Mail Server: (SSL) linux12.znetindia.net (server requires authentication) port 465

    they asked me to rum mail.php to authenticate the process
    so what should i do now so that other than my domain person also get mails.

  2. #2
    Join Date
    Jul 2003
    Location
    California
    Age
    43
    Posts
    4,229

    Default Re: Not able to send mail to other domain alies

    Open-Realty uses the mail() function in php to send emails. If the server is not configured to properly use this function then you may not be able to send emails.
    Open-Realty 2 Documentation

    ~The Difference Between an ORDEAL and an ADVENTURE is ATTITUDE~

  3. #3
    Join Date
    Nov 2008
    Posts
    2

    Red face Re: Not able to send mail to other domain alies

    As you say i discuss this issue with the server technical he has given me the validate code which i have to use in contact.php or wherever i validate for the send mail.

    <?php
    require_once "Mail.php";
    $from = "admin<info@my-domain.com>";
    $to = "Ramona Recipient <recipient@example.com>";
    $subject = "Hi!";
    $body = "Hi,\n\nHow are you?";

    $host = "mail.my-domain.com";
    $username = "info@my-domain.com";
    $password = "user passoword";

    $headers = array ('From' => $from,
    'To' => $to,
    'Subject' => $subject);
    $smtp = Mail::factory('smtp',
    array ('host' => $host,
    'auth' => true,
    'username' => $username,
    'password' => $password));

    $mail = $smtp->send($to, $headers, $body);

    if (PEAR::isError($mail)) {
    echo("<p>" . $mail->getMessage() . "</p>");
    } else {
    echo("<p>Message successfully sent!</p>");
    }
    ?>

    please advice me where should i use this code for validate the send mail

  4. #4
    Join Date
    Nov 2008
    Posts
    8

    Unhappy Re: Not able to send mail to other domain alies

    I am having the same issue. I can send mail through OR to any of the domains on the server... but when i try an outside domain... it appears to go through but the mail never shows up. I have tested a generic php mail() script and it works great.

    Don't know why the OR script will not send.


    Please help... i have racked my brain on this for many hours.

    If the agents e-mail address is one on the server... the e-mail goes through.... and if not... it fails.
    Last edited by trucks; 11-24-2008 at 07:48 PM. Reason: remove url and smtp logs

  5. #5
    Join Date
    Jul 2003
    Location
    California
    Age
    43
    Posts
    4,229

    Default Re: Not able to send mail to other domain alies

    what version of OR are you using? is this a windows server by chance?
    Open-Realty 2 Documentation

    ~The Difference Between an ORDEAL and an ADVENTURE is ATTITUDE~

  6. #6
    Join Date
    Nov 2008
    Posts
    8

    Default Re: Not able to send mail to other domain alies

    v2.5.3
    Yes. MS Windows IIS 6.0

    (Everything seems to be working fine with Windows... except the mail() function for OR... if "windows" is the problem here, do you expect further errors to crop up in the future?)
    Last edited by trucks; 11-22-2008 at 08:46 PM. Reason: Added extra question for Mick

  7. #7
    Join Date
    Nov 2008
    Posts
    8

    Default Re: Not able to send mail to other domain alies

    Problem finally solved... truns out that the error i was having was due to syntax of the email generated from the misc.inc.php file. Had do do a big no-no and remove the chevrons "<" and ">" from around the e-mail address in the from field. Now it works smooth as silk!!!!!!

Similar Threads

  1. send mail problems
    By dr_rude in forum General Help (CLOSED)
    Replies: 0
    Last Post: 12-13-2006, 12:43 AM
  2. Mail send error?
    By locations in forum General Help (CLOSED)
    Replies: 3
    Last Post: 05-28-2006, 02:11 PM
  3. Is this possible? Send mail to agent
    By bit in forum General Help (CLOSED)
    Replies: 7
    Last Post: 09-28-2005, 02:37 PM
  4. Multiple Mail Send
    By prakash in forum HELP (CLOSED)
    Replies: 0
    Last Post: 09-23-2004, 11:59 PM
  5. Contact form on listingview - Could Not Send Mail
    By Ice 9 in forum HELP (CLOSED)
    Replies: 2
    Last Post: 12-30-2003, 01:04 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •