Results 1 to 6 of 6

Thread: a problem with arabic translation

  1. #1
    Join Date
    Feb 2009
    Posts
    7

    Default a problem with arabic translation

    hello;
    I started translating your Open-Realty v2.5.6 into Arabic language but i noticed that there is charset in the control panel and there is no Arabic charset it is "cp1256" and when i tried to put new charset in the controlpanel.inc.php file every thing going very well but there is a problem with the main page in the top ( Warning: html_entity_decode() [function.html-entity-decode]: charset `cp1256' not supported, assuming iso-8859-1 in D:\AppServ\www\Project1\open-realty2\include\page_display.inc.php on line 96 ) how i can fix it. Another problem when i press on the edit link there is a blank page appears with an error in the top (
    Fatal error: Call to undefined function: mb_convert_encoding() inD:\AppServ\www\Project1\open-realty2\include\editor.inc.php on line 148 )
    how i can fix it.

    thanx for reading my problems & I'm sorry if there is mistakes in my post.

  2. #2
    Join Date
    Jul 2005
    Location
    Sao Paulo, BRAZIL
    Posts
    3,763

    Default Re: a problem with arabic translation

    Quote Originally Posted by ahmedg2 View Post
    ....into Arabic language but i noticed that there is charset in the control panel and there is no Arabic charset it is "cp1256" and when i tried to put new charset in the controlpanel.inc.php file every thing going very well but there is a problem...
    Charset CP-1256 is not supported by PHP. Try to use UTF-8 (also DB collation).

    BTW... This is the "Language File Releases" Forum - please, use the "Language help, ideas, discussion & Releases" Forum.

    Thanks,
    Eduardo

    Open-Realty® DOCs
    We can easily forgive a child who is afraid of the dark; the real tragedy of life is when men are afraid of the light. (Author Unknown)

  3. #3
    Join Date
    Feb 2009
    Posts
    7

    Default Re: a problem with arabic translation

    I did use UTF-8 but the words in Arabic not appears correct it is appears in different characters i have to use cp1256 or windows-1256.

    i hope to solve this problem.

    thanks,
    Ahmed

  4. #4
    Join Date
    Feb 2009
    Posts
    7

    Talking Finished of translating into arabic

    Great news guys I'm finished of translating Open-Realty v2.5.6 into Arabic language I'll release it a few days any comments on that I'm want know how many people will use it.... >>> sorry I'm finished translation about 6 months ago and was attend to release it but I had some problems that prevented me of release the translation look to this link this is my problem MODERATED - Violates forum usage rules any one know how to make my laptop hard disk work with PC.
    And I'm was attending to start translate the new releases of Open-Realty new versions but I'm started my own website and I'm don't have time sorry. But I'll try to continue as I can.

    Advise for everyone don't buy HP laptops.

    Thanks,
    Ahmed Jadelrab

    MODERATED - Violates forum usage rules

  5. #5
    Join Date
    Jul 2005
    Location
    Sao Paulo, BRAZIL
    Posts
    3,763

    Default Re: Finished of translating into arabic

    Ahmed,

    Seems you didn't read my post#2. You are posting at the wrong Forum.
    This is the "Language File Releases" Forum - please, use the "Language help, ideas, discussion & Releases" Forum.

    Also, please read this thread:
    http://support.open-realty.org/showthread.php?t=23191

    Thanks,
    Eduardo

    Open-Realty® DOCs
    We can easily forgive a child who is afraid of the dark; the real tragedy of life is when men are afraid of the light. (Author Unknown)

  6. #6
    Join Date
    Feb 2009
    Posts
    7

    Default Re: a problem with arabic translation

    I'm sorry Eduardo.

Similar Threads

  1. Arabic template, is it possible ?
    By Q8T in forum Templates - Help/Ideas/Discussion (CLOSED)
    Replies: 4
    Last Post: 12-30-2008, 12:57 AM
  2. translation problem
    By morfus18 in forum Installation/Configuration Help (CLOSED)
    Replies: 2
    Last Post: 12-25-2008, 06:15 AM
  3. Problem in translation
    By xman in forum General Help (CLOSED)
    Replies: 0
    Last Post: 11-12-2006, 09:45 PM
  4. Problem with translation !
    By marrygbg in forum Installation/Configuration Help (CLOSED)
    Replies: 0
    Last Post: 01-30-2006, 03:05 PM
  5. Translation problem
    By jhuot in forum HELP (CLOSED)
    Replies: 2
    Last Post: 12-07-2004, 09:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •