Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: Strange problems searching on Property Class

  1. #21
    Join Date
    Jul 2005
    Location
    Sao Paulo, BRAZIL
    Posts
    3,763

    Default Re: Strange problems searching on Property Class

    Quote Originally Posted by Scotty View Post
    I'm not trying to be rude lads but I really hate people telling me I am wrong when I know I'm not.
    I ask excuses a second time!
    Seems it is all clear now, huh?

    Eduardo

    Open-Realty® DOCs
    We can easily forgive a child who is afraid of the dark; the real tragedy of life is when men are afraid of the light. (Author Unknown)

  2. #22
    the_sandking's Avatar
    the_sandking is offline hadron remnant - Moderation Fachmann
    Join Date
    Apr 2003
    Location
    Nullspace
    Posts
    5,289

    Default Re: Strange problems searching on Property Class

    Quote Originally Posted by Scotty View Post
    For the last time. When you create a new listing in an UNMODIFIED version of OR it adds a field called 'property_class' to the listingsdbelements table.

    Sandking do me a favour. Go and download a fresh OR. Install it without modifying anything. Add a new property and then go and have a look in the listingsdbelements table. I GUARANTEE you you will have a field in the listingsdbelements_field_name column with the words 'property_class' in it. In the field to the right of that field there will be a number. If you open the classlistingsdb and class tables you will see this number corresponds with both.

    Now go back and edit the property. It does not matter what you do just change something and resave it. Now go back and check the listingsdbelements table and you will see that the field with 'property_class' is now gone.

    Just to make sure I was not going mad I just tested this on fresh download and install and this is what is happening. Do you really think that all the threads on this subject on your forum all made their own field called the field 'property_class' by coincidence? NO. Open Realty does it!

    I'm not trying to be rude lads but I really hate people telling me I am wrong when I know I'm not.
    I was looking at a fresh install originally and in a fresh install there is no 'property_class' in any row in the listingsdbelements table just as I would expect. However, I did not manually add any new listings when I checked this earlier, and now that I have at your suggestion, a property_class entry is present just as you described. I stand corrected.

    OR is adding this as you pointed out (you are not going mad), and I am still very certain pclass info is not supposed to be stored in listingsdbelements at all, and it being present after listing creation is a bug as OR only uses 'class_id' and not 'property_class'.

    CMSrealty was also apparently bugged, and it seems Pbflash has already sorted that.

    If one has not been opened already, I will file an OR bug report.
    "Much of what looks like rudeness in hacker circles is not intended to give offense. Rather, it's the product of the direct, cut-through-the-BS communications style that is natural to people who are more concerned about solving problems than making others feel warm and fuzzy."

    "We gotta' go to the crappy town where I'm a hero!"
    -Hoban 'Wash' Washburne 2485-2519


    "When you’re born you get a ticket to the freak show. When you’re born in America, you get a front-row seat.."
    -George Carlin 1937-2008

    New to Open-Realty® and need help? Check the:
    -OR DOCUMENTATION -

    Important: Read this at least once in your lifetime
    How To Ask Questions The Smart Way

  3. #23
    Join Date
    Jul 2005
    Location
    Sao Paulo, BRAZIL
    Posts
    3,763

    Default Re: Strange problems searching on Property Class

    Quote Originally Posted by the_sandking View Post
    ...and I am still very certain pclass info is not supposed to be stored in listingsdbelements at all, and it being present after listing creation is a bug as OR only uses 'class_id' and not 'property_class'...
    I strongly agree with you. I haven't open a ticket but was talking with Paul - he has a point about it - in my opinion, this will require a brainstorming...
    Please, go and open a ticket!

    Eduardo

    Open-Realty® DOCs
    We can easily forgive a child who is afraid of the dark; the real tragedy of life is when men are afraid of the light. (Author Unknown)

  4. #24
    Join Date
    May 2004
    Location
    Long Island, NY
    Age
    49
    Posts
    9,796

    Default Re: Strange problems searching on Property Class

    CMSrealty was also apparently bugged, and it seems Pbflash has already sorted that.
    All sorted. Don't know what I was thinking when I setup the search module to pass the pclass value as property_class instead of pclass.
    I strongly agree with you. I haven't open a ticket but was talking with Paul - he has a point about it - in my opinion, this will require a brainstorming...
    Maybe a little brainstorming. We just need to change the add listing process to use pclass instead of property_class.

  5. #25
    Join Date
    Jul 2005
    Location
    Sao Paulo, BRAZIL
    Posts
    3,763

    Default Re: Strange problems searching on Property Class

    Quote Originally Posted by pbflash View Post
    Maybe a little brainstorming. We just need to change the add listing process to use pclass instead of property_class.
    No more brainstorming needed! Your solution hits the bull's eye. I have simulated, tested and it works perfectly. Congrats!

    Eduardo
    Last edited by ebmarques; 05-12-2009 at 01:20 AM. Reason: typo :)

    Open-Realty® DOCs
    We can easily forgive a child who is afraid of the dark; the real tragedy of life is when men are afraid of the light. (Author Unknown)

  6. #26
    Join Date
    May 2009
    Location
    Bulgaria
    Posts
    6

    Default Re: Strange problems searching on Property Class

    Many thanks everybody for your assistance and quick solution to this. Much appreciated.

    Chris

  7. #27
    Join Date
    Apr 2009
    Posts
    17

    Default Re: Strange problems searching on Property Class

    Has the solution been implemented in a new download or upgrade option? TT

  8. #28
    Join Date
    May 2004
    Location
    Long Island, NY
    Age
    49
    Posts
    9,796

    Default Re: Strange problems searching on Property Class

    It will be in the next version of OR but it is not a critical update as it really doesn't affect anything within OR.

  9. #29
    the_sandking's Avatar
    the_sandking is offline hadron remnant - Moderation Fachmann
    Join Date
    Apr 2003
    Location
    Nullspace
    Posts
    5,289

    Default Re: Strange problems searching on Property Class

    Quote Originally Posted by pbflash View Post
    It will be in the next version of OR but it is not a critical update as it really doesn't affect anything within OR.
    I will restate this as well for clarity and reinforcement. The unnecessary "property_class" entry in listingsdbelements has absolutely no effect on OR, it simply just should not be there.

    This issue only affects 3rd party applications or add-ons that were erroneously written to look for and/or use it. Such programs should be using the 'classlistingsdb' table and the 'class_id' fields respectively for obtaining property class information for all listings, and should be sending 'pclass' information when calling/using existing OR search functions.

    Paul has already fixed his quick search feature for CMSRealty.
    "Much of what looks like rudeness in hacker circles is not intended to give offense. Rather, it's the product of the direct, cut-through-the-BS communications style that is natural to people who are more concerned about solving problems than making others feel warm and fuzzy."

    "We gotta' go to the crappy town where I'm a hero!"
    -Hoban 'Wash' Washburne 2485-2519


    "When you’re born you get a ticket to the freak show. When you’re born in America, you get a front-row seat.."
    -George Carlin 1937-2008

    New to Open-Realty® and need help? Check the:
    -OR DOCUMENTATION -

    Important: Read this at least once in your lifetime
    How To Ask Questions The Smart Way

  10. #30
    Join Date
    Apr 2009
    Posts
    17

    Default Re: Strange problems searching on Property Class

    Thanks for the clarification. Took a while but all of the lights finally came on! Thanks to Paul for the quick fix in the quick search. TT

Similar Threads

  1. How do I show listings by property class on each class page?
    By prodigious in forum General Help (CLOSED)
    Replies: 0
    Last Post: 06-24-2007, 08:18 PM
  2. Property Class on Search Page and Featured Listings for Property Class
    By pbflash in forum Addon Releases (FREE) (CLOSED)
    Replies: 0
    Last Post: 03-03-2007, 01:42 AM
  3. Strange Problems with O-R and Fedhat or Fedora
    By whitezw in forum Installation/Configuration Help (CLOSED)
    Replies: 0
    Last Post: 03-14-2006, 08:38 PM
  4. Searching within Property Class - how to ??
    By fulltilt in forum General Help (CLOSED)
    Replies: 3
    Last Post: 02-06-2006, 04:47 PM
  5. Strange Intermittent Problems
    By Aristotle in forum HELP (CLOSED)
    Replies: 1
    Last Post: 02-15-2003, 11:20 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •