OK, so here's the scenario:

Running O-R version 2.5.8, upgraded from previous version.
Tried to add a new user, entered all the necessary details.
Hit the add user button, and page goes to "Page cannot be found"
Few second later, an email hits my mailbox with:

Crashed by User at IP --> xx.254.84.13 ON December 15, 2009, 3:46:10 pm

SQL Error Message: Field 'userdb_can_edit_blog' doesn't have a default value SQL statement that failed below:
---------------------------------------------------------
INSERT INTO default_en_userdb (userdb_user_name, userdb_user_password,userdb_user_first_name ,userdb_user_last_name, userdb_emailAddress,
userdb_creation_date,userdb_last_modified,userdb_a ctive,userdb_is_agent,userdb_is_admin,userdb_can_e dit_member_template,
userdb_can_edit_agent_template,userdb_can_edit_lis ting_template,userdb_can_feature_listings,userdb_c an_view_logs,
userdb_can_moderate,userdb_can_edit_pages,userdb_c an_have_vtours,userdb_can_have_files,userdb_can_ha ve_user_files,userdb_limit_listings,userdb_comment s,userdb_hit_count,
userdb_can_edit_expiration,userdb_can_export_listi ngs,userdb_can_edit_all_users,userdb_can_edit_all_ listings,userdb_can_edit_site_config,userdb_can_ed it_property_classes,userdb_can_manage_addons,userd b_rank,userdb_featuredlistinglimit) VALUES
('username','1190','User','Name','username@domainn ame.com','2009-12-15','2009-12-15 15:46:10','yes','yes','no','no','no','no','no','no ','no','no','no','no','no','-1','',0,'no','no','no','no','no','no','no','0','-1')


That's when I notice that, when addind new user, there is no option to set a Blog Related field.

Have we got a fix for this? Thanks!

Anthony