Results 1 to 4 of 4

Thread: SEO urls not working

  1. #1
    Join Date
    Nov 2008
    Location
    Ireland
    Posts
    128

    Default SEO urls not working

    I put this originally in the 3.0 forum but it relates to 2.8

    I have turned on SEO in the admin panel,
    I have changed to .htaccess, (see exact code below)

    Insted of .......index.php?action=calculator&popup=yes
    I now get
    .............calculator.html
    (which is what I want) However
    when I click on the link it gives a broken link error
    see http://www.irish-homes-direct.from-owner.com/

    Have I missed something simple again?????

    Jacqui

    # SEARCH ENINGE FRIENDLY URLS FOR OR 2.5+
    <IfModule mod_php4.c>
    php_value session.use_trans_sid 0
    </IfModule>
    RewriteEngine On
    Rewriterule ^index.html index.php
    RewriteRule listing-(.*)-([0-9]*).html index.php?action=listingview&listingID=$2 [L]
    RewriteRule page-(.*)-([0-9]*).html index.php?action=page_display&PageID=$2 [L]
    RewriteRule search.html index.php?action=searchpage [L]
    RewriteRule searchresults.html index.php?action=searchresults [L]
    RewriteRule agents.html index.php?action=view_users [L]
    RewriteRule view_favorites.html index.php?action=view_favorites [L]
    RewriteRule calculator.html index.php?action=calculator&popup=yes [L]
    RewriteRule saved_searches.html index.php?action=view_saved_searches [L]
    RewriteRule listing_image_([0-9]*).html index.php?action=view_listing_image&image_id=$1 [L]
    RewriteRule logout.html index.php?action=logout [L]
    RewriteRule member_signup.html index.php?action=signup&type=member [L]
    RewriteRule agent_signup.html index.php?action=signup&type=agent [L]
    RewriteRule member_login.html index.php?action=member_login [L]
    RewriteRule edit_profile_([0-9]*).html index.php?action=edit_profile&user_id=$1 [L]
    RewriteRule agent-(.*)-([0-9]*).html index.php?action=view_user&user=$2 [L]
    RewriteRule (.*)-searchresults-([0-9]*).html index.php?action=searchresults [L]
    RewriteRule article-(.*)-([0-9]*).html index.php?action=blog_view_article&ArticleID=$2 [L]
    RewriteRule blog.html index.php?action=blog_index

    #Set Error pages
    ErrorDocument 500 /500.shtml

    Jacqui

  2. #2
    Join Date
    Mar 2004
    Location
    Windsor, Ontario, Canada
    Posts
    380

    Default Re: SEO urls not working

    Try using the .htaccess that comes with OR 3.x. The rewrites are now controlled in the admin with the "seo links" tab

    New .htaccess looks like this

    Options +FollowSymLinks
    # SEARCH ENGINE FRIENDLY URLS FOR Open-Realty
    <IfModule mod_php5.c>
    php_value session.use_trans_sid 0
    </IfModule>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . index.php [L]
    </IfModule>
    #Turn on GZIP Compression in Apache
    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css application/x-httpd-php application/javascript application/x-javascript
    </IfModule>
    # SET 1 Month Cache
    <FilesMatch "\.(ico)$">
    <IfModule mod_headers.c>
    Header set Cache-Control "max-age=2629744, public"
    </IfModule>
    </FilesMatch>
    <FilesMatch "\.(jpg|jpeg|png|gif|js)$">
    <IfModule mod_headers.c>
    Header set Cache-Control "max-age=2629744, public"
    </IfModule>
    </FilesMatch>
    #Set Error pages
    ErrorDocument 500 /500.shtml

    I hope this helps
    Great Templates for your Open-Realty® Website at openrealtytemlates.com
    Need help?, Meet the OR DOC

  3. #3
    Join Date
    Jan 2010
    Posts
    51

    Default Re: SEO urls not working

    I, too, am having this problem. I've tried uploading 3.0.3 htaccess file, but SEO still doesn't work. I've set the space character as - and +, but still get %. Search engines are just not finding me at all. Any suggestions would be appreciated. I've had my site up for over six months now but have had very little luck being found despite lots of relevant content. Thank you.

  4. #4
    Join Date
    Nov 2008
    Location
    Ireland
    Posts
    128

    Default Re: SEO urls not working

    Threre are a lot of things missing from the documentation.
    Two reasons I've found are:
    1. Your server is not using Apache, possibly using Zeus as an operating system. Ive tried translating Apache mod rewrite to Zeus to do the same function but with no success.
    2. There are now 2 .htaccess files one for the site and one for the admin and the code in both are different.
    Here is the code for the root .htaccess, you need to add "RewriteBase /" to the code see below:


    Options +FollowSymLinks

    # SEARCH ENGINE FRIENDLY URLS FOR Open-Realty

    <IfModule mod_php5.c>

    php_value session.use_trans_sid 0

    </IfModule>

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . index.php [L]

    </IfModule>

    #Turn on GZIP Compression in Apache

    <IfModule mod_deflate.c>

    AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css application/x-httpd-php application/javascript application/x-javascript

    </IfModule>

    # SET 1 Month Cache

    <FilesMatch "\.(ico)$">

    <IfModule mod_headers.c>
    Header set Cache-Control "max-age=2629744, public"

    </IfModule>

    </FilesMatch>


    <FilesMatch "\.(jpg|jpeg|png|gif|js)$">

    <IfModule mod_headers.c>
    Header set Cache-Control "max-age=2629744, public"

    </IfModule>

    </FilesMatch>

    #Set Error pages
    ErrorDocument 500 /500.shtml

    Here is the code for the admin again you need to add "RewriteBase /admin/"

    # SEARCH ENGINE FRIENDLY URLS FOR Open-Realty

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /admin/
    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . index.php [L]

    </IfModule>

    Hope this helps.

Similar Threads

  1. SEF urls and where they come from?
    By srobb in forum General Help (CLOSED)
    Replies: 3
    Last Post: 03-30-2010, 01:33 PM
  2. Links/URLS arent working
    By rosslynmorrisrealty in forum General Help (CLOSED)
    Replies: 1
    Last Post: 06-15-2009, 09:36 AM
  3. OR 1 SEO URLs
    By JOsh Beaureagrd in forum HELP (CLOSED)
    Replies: 7
    Last Post: 04-08-2007, 02:48 PM
  4. OR 1 SEO URLs
    By JOsh Beaureagrd in forum Installation/Configuration Help (CLOSED)
    Replies: 0
    Last Post: 04-03-2007, 04:00 PM
  5. help for seo urls
    By sonli in forum General Help (CLOSED)
    Replies: 2
    Last Post: 03-21-2007, 04:41 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •