Results 1 to 5 of 5

Thread: Adding Polish language

  1. #1
    Join Date
    Jul 2010
    Posts
    18

    Default Adding Polish language

    I installed English version 3.0 and it works. Then I tried to have Polish version (for good translation of certain phrases it's better to have working model then pure file).

    I made pl subcatalog in install catalog install/lang/pl/lang.inc.php as well as in include (include/language/pl/custom/). When I try to make new instalation in Polish version I cannot choose pl language because it is not in menu in step 1 of installation.

    Does it need change in install index.php file?

  2. #2
    Join Date
    Jul 2005
    Location
    Sao Paulo, BRAZIL
    Posts
    3,763

    Default Re: Adding Polish language

    Users cannot just add a new language to Open-Realty.
    But users can help O-R to have a new language - if you wish to help, here is the start:
    http://support.open-realty.org/showthread.php?22328
    If you don't wish to help, you need to install O-R (lets say in English) and then AFTER installed, you need to REPLACE the language files inside the English folders ("en" folders) - don't rename the folder otherwise O-R will ignore the folder.
    Of course, you can also translate the INSTALL language files (from English to Polish) and you will have a fake "English" installation.

    Assuming an English installation, I recommend you to insert your Polish language files at: ../include/language/en/custom
    Having your files inside the "custom" folder you don't lose the translation at future upgrades.
    Good reading: http://open-realty.org/docs/release/...11180676144842

    Eduardo

    Open-Realty® DOCs
    We can easily forgive a child who is afraid of the dark; the real tragedy of life is when men are afraid of the light. (Author Unknown)

  3. #3
    Join Date
    Jul 2010
    Posts
    18

    Default Re: Adding Polish language

    Thank you Eduardo for answer. I trayed method you mension and it works but not with typical Polish characters - instead of them it shows square box (translation was made with UTF-8 editor ON). What more when I put "pl" file in place of "en" file OR logo doesn't show.

  4. #4
    Join Date
    Jul 2005
    Location
    Sao Paulo, BRAZIL
    Posts
    3,763

    Default Re: Adding Polish language

    Quote Originally Posted by rental View Post
    I trayed method you mension and it works but not with typical Polish characters - instead of them it shows square box (translation was made with UTF-8 editor ON).
    I have no idea what you mean with "UTF-8 editor ON". We usually say that all users should use a text editor and SAVE FILES encoded as UTF-8 (without signature) - I do not recommend to use Windows Notepad, but I do recommend Notepad2 or Notepad++
    Having your language files encoded as UTF-8 will also require from you to set the charset of your Website the same (UTF-8). Also... the database collation.

    Quote Originally Posted by rental View Post
    What more when I put "pl" file in place of "en" file OR logo doesn't show.
    O-R logo has nothing related to language files.
    So we can only assume you have a lang tag in place of YOUR logo (of course, a logo is an image file not a language file).
    The PHP variable (related to your lang tag) most probably has a wrong path to the image file.

    Eduardo

    Open-Realty® DOCs
    We can easily forgive a child who is afraid of the dark; the real tragedy of life is when men are afraid of the light. (Author Unknown)

  5. #5
    Join Date
    Jul 2010
    Posts
    18

    Default Re: Adding Polish language

    Almost everything is OK!. It was my fault to use UTF-8. I should use UTF-8 without BOM. This little distinction made a lot of distortion in templates.

    Admin can close this topic. Thanks!
    Janusz

Similar Threads

  1. polish language pack
    By kukn in forum Language File Releases (CLOSED)
    Replies: 1
    Last Post: 01-09-2008, 11:19 PM
  2. Adding another language
    By tonynoriega in forum General Help (CLOSED)
    Replies: 4
    Last Post: 11-01-2007, 06:23 PM
  3. Adding language tag to a template
    By gbryanmiller in forum General Help (CLOSED)
    Replies: 2
    Last Post: 01-27-2007, 12:43 PM
  4. Polish language pack?
    By orphano in forum HELP (CLOSED)
    Replies: 2
    Last Post: 01-13-2006, 03:06 PM
  5. Polish language pack?
    By orphano in forum Mods (CLOSED)
    Replies: 0
    Last Post: 04-28-2005, 05:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •