I am using an old version of OR v2.4 and I want to upgrade to php 5.2.0. Will this cause any problem, is v2.4 compatible with a higher version of php and mysql?

Help is greatly appreciated.

Arly