Results 1 to 4 of 4

Thread: Will Open Realty 2.5.8 run on PHP 5.3.x

  1. #1
    Join Date
    Aug 2004
    Location
    Memphis, TN
    Posts
    45

    Default Will Open Realty 2.5.8 run on PHP 5.3.x

    Looking at the requirements for 2.5.8 at
    https://docs.google.com/View?id=dhk2...77455036082179
    Says it will run on "PHP 5 or higher"

    Just need to verify it won't die if I upgrade the server to PHP 5.3.6, I've still got a couple of 2.5.8 sites I haven't upgraded because of modifications but I've got some other applications that will now require PHP 5.3.2+ to run.

    If there are mods that need to be done to OR 2.5.8 to run under PHP 5.3 please let me know so I can get a temp solution at least. I know that a lot of scripts that "break" in PHP 5.3 really only need E_DEPRECATED turned off in php.ini to run.

    Thanks,

  2. #2
    the_sandking's Avatar
    the_sandking is offline hadron remnant - Moderation Fachmann the_sandking is on a distinguished road
    Join Date
    Apr 2003
    Location
    Nullspace
    Posts
    5,289

    Default Re: Will Open Realty 2.5.8 run on PHP 5.3.x

    Nope, PHP v5.3 support is one of many reasons OR v3 was released last year when OR v2 was discontinued. The last update to v2.x was in 2009.
    "Much of what looks like rudeness in hacker circles is not intended to give offense. Rather, it's the product of the direct, cut-through-the-BS communications style that is natural to people who are more concerned about solving problems than making others feel warm and fuzzy."

    "We gotta' go to the crappy town where I'm a hero!"
    -Hoban 'Wash' Washburne 2485-2519


    "When you’re born you get a ticket to the freak show. When you’re born in America, you get a front-row seat.."
    -George Carlin 1937-2008

    New to Open-Realty® and need help? Check the:
    -OR DOCUMENTATION -

    Important: Read this at least once in your lifetime
    How To Ask Questions The Smart Way

  3. #3
    Join Date
    Dec 2006
    Posts
    39

    Default Re: Will Open Realty 2.5.8 run on PHP 5.3.x

    I'm running all my OR v2.58 test sites on Php 5.3.x and currently I've had no problems.
    What problems should I be getting?
    Thanks

  4. #4
    the_sandking's Avatar
    the_sandking is offline hadron remnant - Moderation Fachmann the_sandking is on a distinguished road
    Join Date
    Apr 2003
    Location
    Nullspace
    Posts
    5,289

    Default Re: Will Open Realty 2.5.8 run on PHP 5.3.x

    Your server configuration is set to suppress errors.

    Set PHP's error_reporting to E_ALL and you and your site visitors will see them.
    "Much of what looks like rudeness in hacker circles is not intended to give offense. Rather, it's the product of the direct, cut-through-the-BS communications style that is natural to people who are more concerned about solving problems than making others feel warm and fuzzy."

    "We gotta' go to the crappy town where I'm a hero!"
    -Hoban 'Wash' Washburne 2485-2519


    "When you’re born you get a ticket to the freak show. When you’re born in America, you get a front-row seat.."
    -George Carlin 1937-2008

    New to Open-Realty® and need help? Check the:
    -OR DOCUMENTATION -

    Important: Read this at least once in your lifetime
    How To Ask Questions The Smart Way

Similar Threads

  1. How to build an Open-Realty 2.x Style Slideshow in Open-Realty 3.x
    By greengiant in forum Templates - Help/Ideas/Discussion
    Replies: 9
    Last Post: 04-23-2011, 10:11 AM
  2. Upgrading Open-Realty 2.x Templates For Open-Realty 3.x
    By greengiant in forum Announcements
    Replies: 0
    Last Post: 06-24-2010, 03:16 PM
  3. Replies: 0
    Last Post: 05-31-2010, 04:19 PM
  4. Open-Realty 1.1.5b to Open-Realty 2.0 Upgrade Notes.
    By greengiant in forum HELP (CLOSED)
    Replies: 20
    Last Post: 12-07-2007, 10:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts